Поиск решение проблем Asterisk.

Данная статья посвящена решению проблем со звонками в Asterisk. В ней подробно расскажу принципы решения возникающих проблем с Asterisk.

Работа с лог файлами.
Как известно все программы пишут свои лог файл, в которые записывают что произошло, что вызвало ошибку, куда не получилось получить доступ и так далее.
Читать далее

Mikrotik MIP (mapped ip)

Назначаем внешний айпи на интерфейс

Создаем два правила

/ip firewall nat add chain=dstnat dst-address=<ext ip> action=dst-nat to-addresses=192.168.1.179
/ip firewall nat add chain=srcnat src-address=192.168.1.179 action=src-nat to-addresses=<ext ip>

Mikrotik export/import config

/system backup

Для сохранение

[admin@MikroTik] system backup> save name=test
Configuration backup saved
[admin@MikroTik] system backup>

Для восстановление
[admin@MikroTik] system backup> load name=test
Restore and reboot? [y/N]: y
...

CVE-2019-9670 Zimbra

1. cd /usr/bin/; mv wget wget.disabled
2. cd /usr/bin/; mv curl curl.disabled
3. remove zmcpustat, zmcpustater and various files as twuopuuk, tergshwfd, reriwjdfd, afgejjdhd … with 750 in /opt/zimbra/log
4. remove */30 * * * * /opt/zimbra/log/zmcpustater from /var/spool/cron/crontabs/zimbra
5. reboot

Update ZCS

Copying a Hyper-V vhd server to a VMWare vmdk machine the ‘easy way’

First: there isn’t a quick and easy tool to migrate a Hyper-V machine to a vSphere ESXi machine… but luckily it’s doable if following the rules. Reserve enough time for the conversion and upload process. We will call the source and destination virtual machine w12a in this example. The VmWare datastore is called ds1.

  1. Make sure you have enough free space to store a fixed size hard disk copy of the source vm. USB storage will work too.
  2. Shut down the source Hyper-V VM. When this guest runs MS Exchange make sure to first stop and disable all MS Exchange services.
  3. Convert the VHD file with StarWind V2V Convertor to a “VmWare ESX Server image”. Do not choose “VmWare growable image” because you can’t edit the size of a vm workstation virtual hard disk on ESXi! The time this will take depends…  in my case a 200 GB file took 31 minutes (6.45 GB/min). A 5.12 GB growable VHD took 16 minutes. This is  because it’s configured at 100 GB size (makes 6.25 GB/min)… So take into account the configured total size. The convertor will create fixed size hard disks. This also means you can speed up the process by temporary making your VHD hard disks smaller if possible.

Читать далее